Z axis always moves laser to top of limit switch when I start burn

I have a Silverback 6060 with a 40 watt laser and I’m using LightBurn. Before I start the burn, I get the laser set up to the proper height and then once I’m ready to go and hit start, the laser always goes up to the top limit switch. This brings the laser 3 to 4 inches above the material, so nothing burns. Is this some sort of setting or am I missing something?

LightBurn shouldn’t be moving the Z axis at all, so that’s definitely a strange one…

The only Z axis controls are usually reserved for the CO2 machines, so something is awry in the setup somewhere.

When using the jog functions within the software, are all the normal movements correct?

Yes it functions fine when I move it from LightBurn. I did shut off the enable z axis in device settings and that seem to work but everything I have watched says turn that on.