Y2 axis only moves in the Y+ direction

Silverback 6060 1mx1m.
Began homing sequence and the Y2 axis only moves in the Y+ direction, home is the front left corner of the machine.
I unplugged the cable and verified continuity with all four wires using a volt/ohm meter. I turned the controller off and removed power from the unit for approximately 10 minutes, no change. Pressed the reset button on the front of the unit, no change. Swapped the Y1 and Y2 axis cables and the problem followed to the Y1 motor.
Did my controller card go out or is there something else I need to do?
It worked fine just a few days ago.

Can you explain your problem a little more please. From what I am understanding your machine is homing in a direction that you dont expect it to. Can you jog all axis fine?

When I was homing the machine prior to starting a carve the Y2 stepper motor was only turning in one direction, regardless of the way it was supposed to go. I worked with Geno last night and it was the microstepper driver that has failed. No different than telling kids to pick up around the houseā€¦and they go outside and pick up around the house. Doing what you told them, but not.

Thank you for trying to help, I truly appreciate it.