Unable To Get Spindle running

Hi I have just setup my new Silverback and trying to get the spindle to run and for the machine in Easel to complete the limit switch setup. Have tried to=the only options in Easel set those being Hardware, Manual and Other. But none work even after changing out the usb cable, rebooting computer, reset the Silverback and changing power settings.
For the limit switch test it completes the Z axis test then goes to do X and Y but stops on the left hand side of the X axis and have to wind away from the limit switch and then reset both the machine and easel.
Any ideas thanks. Have contacted support but different time zones makes it hard to get a early answer.

It sounds like you may have a couple different problems here

  1. homing
  2. spindle operation

As for homing you will want to verify that the limit switches are working properly. you can open Machine inspector in Easel by pressing Crl+Shift+D (or going to Machine>General Settings>Machine Inspector) Then in there are some circles and if you can press each switch by hand and verify the correct white circle turns green, that will verify the limit switches are working properly.
Then If they do you can initiate a homing cycle from within there by entering the following command into the console section and pressing enter:
$h

this will home the cnc and you can also watch for the white circles to turn green AND IF it fails the status will indicate “alarm” and there will be a line a little down the console section indicating the reason for the fault, if you can retrieve that alarm number (not the error number, as the error is a result of the alarm and doesn’t matter as much to determine the fault)

As for the Spindle operation, Setting of “hardware” control and “other” type will result in the spindle relay activating in the Silverback Controller box, However the Knob will control the speed, so you will need to ensure the knob is turned up when or the spindle will remain still if the knob is turned all the way down. (this is the usual cause so I’m not really going to go into other less likely but possible reasons until you can double check this, thanks!)

Hopefully those tests can help guide us towards the right root causes.

Thanks The limit switches verify as working but When setting up in Easel it only runs Z axis then to Xaxis then stops with switch on the left side. It doesn’t touch then back off slightly like the Z and Y is the same it just hits the switch and stops.
The spindle is turned up full and is set on hardware and Other. I tried also 24VDC but that didn’t work. So nothing makes the spindle work in either and UGS which shows alarm for the spindle.


Um, in that photo it shows it set to “manual” so I’m sorry to say it once more, but it needs to say “hardware” and to click the save button at the bottom to save that setting. . .

Also that “alarm” being there as greyed out actually means that there is no alarm occurring otherwise it would be red. And also it applied to the entire CNC, not just the spindle and like Easel ,there will be an alarm number in the console section when it does alarm.

Did you try sending that homing command and watching the circles go from white to green during the homing cycle and check for an alarm (all in easel)?

Yes did watch and it just goes white after hitting the X limit switch when it stops and neither axis do a complete cycle. I sent the Y axis to the rear and it just crashes and groans when it hits the end plate. I have checked all wiring and all are correct connection. I think there must be something wrong with the control box as it is not working in other software as well.

1 Like

welp, one issue I see in UGS is this Tool Change line. which is not supported. So I’m not sure where this gcode file came from (it wasn’t easel) but this T1 line needs to be deleted, plus the cnc is offline, you’d need to click this icon to connect and then it might work better…

if you can get that alarm number that would be most helpful.
Thanks!

Thanks Seth getting a bit frustrated as I didn’t have any trouble at all getting the 3018Pro running. How do I delete the tool change setting. The Gcode file was part of a Carveco Maker file I had setup for running on the 3018
I have been through the machine setup in UGS but it all comes to an end when I get to the Limit switch setup and homing. The switches test all good but when I run the test thats when the X axis just goes left and hits the switch and locks all up until I wind back the lead screw to release the switch and reset the control box and UGS. Same thing happens with Easel so I don’t know what to do now. I am only a newbie with these machines

1 Like

For the T1: You could manually delete that line out using a word processor (MS word, or Notepad work) . . And In Carveco I would use the post processor of “grbl” in mm or inches as this are the most universally accepted version. and won’t include the tool number up there.

As for the limit switches, In Easel when you do the $h and watch the circle for X change from white to green, does it change back to green, or does it remain green when it stops. Also when you are able to run this again in Easel, that Alarm number will correlate to a chart, here’s that chart.
https://awesome.tech/gerbils-alarm-error-and-option-codes/
the Alarm could be #8 or #9 which are 2 different problems, not to be confused with Error#8 which will appear regardless of whether it’s actually Alarm#8 or #9.

IF the alarm is #8 then you may need to adjust the Homing Pull Off amount in the grbl settings (this is setting $27)

IF the alarm is #9 then the switch OR the stop plate might need to be moved a little closer because it isn’t reaching the plate to actually trigger the switch and instead it’s hitting something else first that’s causing it to physically stop before pressing the switch.

Thanks mate for your help really appreciate it taking time out of your weekend . the X axis is not moving at all now in Easel or UGS. I have rebooted the computer and turned the control box off and have had it rest for 5 minutes restarted and reset the box but still no x axis movement.
I will move the rear limit plate on the Y axis to see if that will stop the crashing at the rear.
But not sure what to do with the X-axis I have undone the power cable and re connected with out any luck. Does the rest button on the control box reset everything like the stepper motors or just the limit switches.
The X axis motor never loads up at the end of the left hand late it just hits the switch and stops. So weird

I get an Error code 8 in UGS but get no messages in Easel. Easel just doesn’t do anything I can’t do any setup in easel without hit limit switches but still can’t get spindle to work.
I got the spindle to work in UGS until it went to the home position at the front of the spoil board and hit the limit switch so don’ t know how to set up home position that doesn’t exceed the limit switch.
I also fixed the problem with the Y axis hitting at the rear. It was the bracket for the link chain setup in the top rail not the bottom slot of the rear rail

Hi Seth. I ended up having to set the Silverback up in Easel as an Other/GRBL machine and not using the Easel Yorahome Silverback 6060 machine profile. It worked fine after that although I didn’t go through the homing setup. I will try that when I get bit more experience with the machine. It appears that something is wrong with Easels profile for the Silverback
Thanks for your help and explanations.
No good with homing, the machine just does a limit switch test at front left for the X Y & Z then locks everything and loses power etc.

1 Like

Hi Carey
Your settings are out - check the ones with in bold!

Below are the default settings for a 6060 Controller; these can be used for reference in the event something has been changed on your board.

$0=10 (Step pulse time)
$1=255 (Step idle delay)
$2=0 (Step pulse invert)
$3=0 (Step direction invert) (NOTE - do not change this value if your machine movement is correct; this may vary for your machine)
$4=0 (Invert step enable pin)
$5=0 (Invert limit pins)
$6=0 (Invert probe pin)
$10=115 (Status report options)
$11=0.010 (Junction deviation)
$12=0.002 (Arc tolerance)
$13=0 (Report in inches)
$20=0 (Soft limits enable)
$21=1 (Hard limits enable)
$22=0 (Homing cycle enable)
$23=3 (Homing direction invert)
$24=25.000 (Homing locate feed rate)
$25=500.000 (Homing search seek rate)
$26=250 (Homing switch debounce delay)
$27=3.000 (Homing switch pull-off distance)
$30=10000 (Maximum spindle speed)
$31=0 (Minimum spindle speed)
$32=0 (Laser-mode enable)
$100=160.000 (X-axis travel resolution)
$101=160.000 (Y-axis travel resolution)
$102=160.000 (Z-axis travel resolution)
$110=2000.000 (X-axis maximum rate)
$111=2000.000 (Y-axis maximum rate)
$112=2000.000 (Z-axis maximum rate)
$120=300.000 (X-axis acceleration)
$121=300.000 (Y-axis acceleration)
$122=300.000 (Z-axis acceleration)
$130=600.000 (X-axis maximum travel)
$131=600.000 (Y-axis maximum travel)
$132=55.000 (Z-axis maximum travel)

1 Like

Hi Mark do I just use the machine inspector console to change these settings to your list and will they stay in there permanently?

1 Like

Yes, enter one as a time in the console part of machine inspector you need only type the part of each line prior to the brackets and hit enter to send. When they have each been entered, you can scroll to the bottom section and after clicking the small refresh button at the bottom to update the current ones shown you can verify they all match the ones provided here.

And they are semi-permanent. . . they will remain as set so long as when a machine setup is done in Easel one does not pick one of the Inventables cnc options as that will automatically push that machines (one of the X-Carves) settings to your silverback and they are not identical settings. . . OR you manually type them in at a later date. . . OR you update the grbl version.

I like to keep a copy of the current settings with the machine as a back up reference.

Thanks Seth, will do

1 Like

Yes please, and they will stay as long as you don’t change them with the mystical magnetic powers of the southern hemisphere :stuck_out_tongue_winking_eye:

1 Like

Thanks mate I only ever selected the Silverback profile to start with then when that didn’t work I chose the GRBL setup so that may have changed the settings.

1 Like

Only the inventables machine from that main screen actually push new settings, so long as you selected “other 3rd party machine” then Easel wasn’t the cause of the settings change. . .

However I’ve seen others report that after the last UGS update, that if UGS is opened for the first time after an install and the CNC is plugged in, it might set the grbl settings to the grbl defaults. Which are different values than the Easle change thing.

Thank you very much I now have control of the Silverback now. In the Machine control it doesn.t come up with to set up Homing or Limits. Do I use $= setting to run homing?

Thanks Seth how do I prevent UGS from doing the changes to GRBL and does it change the settings each time you go into UGS. Would there need to be a Macro or something to run after loading UGS.

Mainly ask as I do up a project in Carveco Maker then run the cut in UGS which seems the simplest way to do it I have found