Spindle not working on 6060

I have tried everything I can find listed in this forum and on the web to help me with this problem. The spindle that comes with the 6060 will not turn on. This is a brand new machine. I’m using easel, and when I go to carve something set my z and then my xy zero. Moves to the spindle and it never comes on. I have it set to hardware in the settings. I’ve even tried to setup the machine as other and set the spindle to automatic but nothing changes. I can hear a noise in the control box like it is turning on but nothing happens. I’ve test connectivity for the wire with my multi meter, I’ve test the ohms on the spindle. Everything thing seems fine. I feel like it is something simple I’m missing but can’t figure it out. I did put my trim router in and was able carve out a item with no issue at all. Just ant get the spindle to activate. I did try to see if I have any voltage at the back terminal when I tell it to activate but nothing happens.

Just wanted to post the solution on here since I don’t see a lot of that. It was a loose wire in the control box for the power supply to the spindle. Thanks to Yorahome Support for helping me out.

Tha ks for that update! Sorry jo one got to you sooner.