Machine won’t stay on zero zero

When I put the machine in the bottom left corner then start light burn, as soon as I try to move it, it goes to X:78 and Y: -69

This is the first time I’ve had this problem, I do t k ow how it happened or how to fix it! Please help!!!

It does the exact same thing in both light burn and lasergrbl

Which machine are you using?

Keep in mind that machines without limit/homing switches truly have no idea where they are physically located, and you must set the origin manually.

I’m using the 3018 pro with extension kit… I’ve used this machine for a solid month and all I’ve had to do is set it at the bottom left corner manually and restart light burn and it uses the position at start up as 0,0 for the duration of my session. Just last night it kept popping up a dialog box saying it lost steps and recommended that it be re zeroed because the position could not be guaranteed. This is the first time I’ve ever had that happen… what would cause that? Before yesterday I never had to reset zero during a session…

Did you change anything related to speeds in Lightburn? If you try to run at too high a speed (beyond what the machine is capable of), it will “lose” those steps as it attempts to move.

Any recent updates to the software, that may have caused some options to return to defaults? This has happened on occasion with software updates in LB

I didn’t make any speed changes but I did do an update on software, the strange thing is I had used the software after the update with no problems for three or four days before the problem happened…

I would double check the starting position and coordinates settings, just for good measure.
If it decided to change from user position to absolute coordinates, that will cause it to do strange things.

Lightburn sets the 0,0 point to where the laser is when you turn the machine off. I have to home and make sure the Get Position button is pushed to get it to reset to 0,0. Am having issue with fact that anytime ORIGIN is used it goes to upper right which is machine 0,0. Can’t get the User origin to work so I use current position or absolute settings.

I have to turn the machine off after homing. Left that off previous post.