3036 -- Spindle turns when installing machine, but NOT when getting ready to carve

During the steps of installing the machine, the drill turns on every time.

When sending a design for carving, while going through the set-up steps (verify material height, homing the machine), the drill usually does NOT turn on after the “Raise the drill” step.

It has worked intermittently, and then has STOPPED working when sending the next design while making NO changes to any settings.

Perhaps there are grbl settings to change?

No, grbl settings will not effect this.

What may effect this would be a splice/intermittent dissconect in the wires
Hitting a limit switch when raising spindle to turn on
E-stop is depressed

As i mentioned before, could be the easel driver, i have had issues with the driver for other operations. (Unsure if they have fixed it yet)

A video of what your doing, where the z axis is, would be hugly benificial. Either upload one here or to the facebook user group.


Will do.
I’ll do my best with the video while holding the phone at the same time.

I’ll do a very small design on 3/4" cedar, with a 1/8" bit.

Back soon.

Thanks very much. I can’t imagine it’s a very complicated issue. Other than this hurdle, the machine is excellent.


I’ll post to the Facebook group.
I can’t put an mp4 file here.

– Van


It’s in a pending post (not yet approved) on the YoraHome CNC Users Group (on Facebook).

Please let me know if you need me to send you the gcode file from Easel.

– Van

Notice to anyone seeing this post:

PROBLEM RESOLVED, thanks to help from the team at YoraHome.

The problem turned out to be that the spindle was mounted too high, and so the mechanism was hitting the Z Limit when the drill was raised to move into position.

After a simple adjustment (lowering the spindle by 1 inch), it’s working like a charm!

THANK YOU for the help.